[Jitsi] Comment changer le port UDP (10000 par défaut)?

#1

(question posée par pvincent sur la mailinglist)

Bonjour,

Je confirme aussi le côté “gourmand” des connexions réseaux avec Jitsi Meet.
Du peu que j’ai compris, quand on est 2, on travaille en mode pair-à-pair => super :slight_smile:
Puis dès qu’une troisième personne se connecte, jitsi-video-bridge (jvb) prend le relai et autorise le principe de visio-conférences multiples.
Du coup, c’est le serveur qui centralise les connexions réseaux, et ça monte vite en bande passante => 1.5.Mb / participant en moyenne

Par rapport au chaton zourit.net, j’ai aussi constaté des liens explicites dans les fichiers de configuration vers des serveurs Google .

pas cool. Sans trop savoir de quoi il s’agissait, j’ai laissé par défaut.

En revanche, là ou j’ai le + galéré c’est sur le changement du port UDP 10000 par défaut. Très dur d’avoir la moindre documentation.

Cela devient problématique si on est dans le cas de gestion par container (LXC) et qu’il faut faire du NAT vers plusieurs instances.

Sans la possibilité de changer ce port, j’en suis arrivé à la conclusion qu’il fallait disposer d’adresses IP différentes pour jongler entre plusieurs instances de Jitsi Meet, bref pas idéal.

Le pire c’est que j’ai vu une doc à propos d’un docker JitsiMeet qui permettait de le faire, mais ça devient un jeu de piste !

La documentation n’est pas très explicite à ce sujet.

Voila pour ma petite expérience avec Jitsi Meet pour zourit.net,

si vous trouvez une parade pour le port 10000, je suis très preneur.

–pvincent

#2

De ce que j’ai compris, non. Tout passe toujours par le jvb, je suis sur à 99%. Je serais content d’etre contredit :slight_smile:

Je viens de faire cette pull request:

Le param exact dans nginx, je ne saurais dire, j’utilise kubernetes, et chez nous, cela ressemble à cela:

Mais en gros, avec le NAT, c’est la grouille…Le mieux est que ton videobridge ait son IP, son port 10000, qu’il connaisse son IP, et ça va bien se passer.

De toute façon, le facteur limitant est la bande passante, donc pas besoin de mettre plusieurs videobridge par host.

#3

C’est possible !
J’ai du pas mal chercher, mais ça se fait.
Du coup, pour que ça fonctionne, ça se passe par là.
Il faut créer un fichier application.conf qui contient

videobridge {
    ice {
         udp {
            port=<ton port>
         }
    }
}

et lancer ton videobridge avec l’option -Dconfig.file=/path/to/application.conf
ou alors le mettre dans le classpath de ce que je vois de la doc.
J’espère que ça sera suffisant :slight_smile:

2 Likes
#4

Cette doc, c’est pour videobridge2 qui n’est pas encore dans le paquet stable, mais juste dans le testing.
(comme si c’etait deja pas assez compliqué hein :slight_smile: )

Je pense du coup que pour changer juste le port:


Mettre JVB_PORT=10001 dans /etc/jitsi/videobridge/config
Je pense, pas sur a 100%.

2 Likes
#5

Oui ça doit marcher aussi mais je n’ai jamais testé cette méthode.

#6

super, merci @pierre et @Gu1nness,
j’essaye ça la semaine prochaine, je vous tiens au courant.
ça me semble cohérent.

et merci @pyg d’avoir re-routé vers le forum.
en effet, plus pratique et convivial qu’une liste de discussion.
j’utiliserai en priorité ce canal à présent.

1 Like
#7

Bonjour,

as tu pu tester ?
J’ai un problème je pense similaire au tien.
Un container LXC sur proxmox . Tout fonctionne … sauf jitsi-meet … .
Dès que quelqu’un vient se rajouter à ne réunion, cela plante.
J’ai essayé de forcer le port à 10000 en ajoutant JVB_PORT=10000, mais cela ne semble pas résoudre le problème …

De même que la vérification du /etc/hosts …

#8

Ok donc ca marche, mais pas sur Firefox, et tout par défaut, sauf le /etc/hosts qu’il faut vérifier

#9

Alors j’ai un peu galéré, mais je crois que là ça fonctionne sur FF
Tant que c’est à peu près clair dans ma tête, il me faudrait rédiger ce que j’ai fait dans le wiki chaton.

Tu peux tester sur https://meet.alolise.org

#10

Alors j’avoue que là ça marche bien donc je me touche plus à rien :slight_smile:

#11

oops, pas eu le temps de tester, désolé.
pris dans un cercle de corona-conflit-de-priorité :slight_smile: