Bug avec libreto

Bonjour,
je trouve un bug avec Libreto sur mon serveur et sur le votre aussi apparement… Vous sauriez si c’est lié àux mise à jour de Yunohost ??

En cliquant sur Écrire j’ai ce message:

Quelqu’un saurait comment corriger ce bug innatendu ? Ou est-ce que ça vient de mon navigateur ? de ma connexion partagée avec un smartphone ??

Bon, toujours pas de solution, j’ai ouvert une issue sur le projet:

Est-ce que vous aussi vous avez ce soucis ? ici par exemple: camp-chatons-2022 - Libreto

Zut je découvre que c’est un bug avec le navigateur !! firefox-91.13.0.esr(64bits), je viens d’essayer d’installer Epiphany et il ouvre bien les pads en écriture !! ou alors un problème avec mes extensions…

Trouvé ! c’est l’extension DuckDuckGo Privacy Essentials qui créé ce bug quand elle est activée !! pardon pour ce post…

1 Like

Pas de soucis, j’ai pas eu le temps de te répondre avant que tu trouves.

Ça peut aussi arriver en utilisant des pads d’un autre nom de domaine que celui du libreto (et en fonction des header HTTP genre CSP et compagnie).

Par contre, libreto n’est pas très bien optimisé et du coup il faut adapter l’etherpad un peu si il y a beaucoup d’usagers en éditant la propiété importExportRateLimiting

Ci-dessous un petit hook pour que ça s’applique après chaque upgrade d’etherpad

/etc/yunohost/hooks.d/post_app_upgrade/05-etherpad_mypads

#!/bin/bash

source /usr/share/yunohost/helpers
app=$YNH_APP_INSTANCE_NAME

if [[ "$app" == "etherpad_mypads" ]]; then
  ynh_write_var_in_file --file=/var/www/etherpad_mypads/settings.json --key=max --value=100 --after=importExportRateLimiting
  systemctl restart etherpad_mypads
fi
1 Like

Super, merci, du coup j’ai éditer ce ficher et un sudo yunohost app upgrade libreto -F pour lancer le script, je peux maintenant accéder à la page en laissant l’extension activée…